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Copyright

o Copyright © 2019-2020 Ing. Federico Joaquín (federico.joaquin@cs.uns.edu.ar)

o El uso total o parcial de este material está permitido siempre que se haga
mención explícita de su fuente: “Notas de Clase. Estructuras de Datos.”
Federico Joaquín. Universidad Nacional del Sur. (c) 2019-2020.

o Las presentes transparencias constituyen una guía acotada y simplificada de la
temática abordada, y deben utilizarse únicamente como material adicional o de
apoyo a la bibliografía indicada en el programa de la materia.

2lunes, 27 de abril de 2020

http://cs.uns.edu.ar/~federico.joaquin/


Recursos 
adicionales
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Enlaces externos de interés

o Acceda a información útil mediante enlaces externos a:

• código fuente disponible de forma online.

• otro material disponible de forma online.
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GENERACIÓN 
AUTOMÁTICA DE 
DOCUMENTACIÓN:
JAVADOC

4lunes, 27 de abril de 2020

Se recomienda que todo lo documentado en la siguiente sección sea complementado a través de
otras herramientas multimedia dispuestas en la siguiente explicación online.

https://cs.uns.edu.ar/~federico.joaquin/web/explanations/students/ed/herramientas-utiles-para-tdas
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¿Qué es Javadoc?

o Javadoc es una utilidad de Oracle para la generación de documentación de
APIs en formato HTML a partir de código fuente Java.

o Javadoc es el estándar de la industria para documentar clases de Java. La
mayoría de los IDEs los generan automáticamente.

o Se deben utilizar los comentarios especiales /** … */ con algunas palabras
claves para determinar la documentación.

5lunes, 27 de abril de 2020

En esta materia se busca que los alumnos aprendan y ejerciten la tarea de
documentar sus soluciones de software, considerando la siguiente premisa:
cualquier persona ajena al código desarrollado y que lo desee utilizar, debe poder
con la documentación interpretar qué hace, y cerciorarse cómo es que se usa.



Estructuras de datos – 1º cuatrimestre  2020

¿Cómo documentar una API?

o La correcta documentación de una API es fundamental para los clientes
que van a utilizarla. En cierto sentido, es una garantía de un producto final
de la mayor calidad.

o Se debe describir de forma precisa y completa (sin entrar en detalles de
implementación), aquellos elementos que forman parte de la API: clases,
métodos, excepciones, etc.

o Los comentarios están destinados y serán utilizados por los clientes de la
API documentada. Por esto, es imprescindible que las precondiciones,
parámetros, valores de retornos, excepciones, etc., sean completamente
definidas, para su correcto uso.

6lunes, 27 de abril de 2020
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Ejemplo: documentando código (no Javadoc) 

7lunes, 27 de abril de 2020

public class Calculadora {
public static float a(float b, float c) {…}

}

cualquier persona ajena al código desarrollado y que lo desee utilizar, debe poder con 
la documentación interpretar qué hace, y cerciorarse cómo es que se usa.

“
”

https://cs.uns.edu.ar/~federico.joaquin/web/explanations/students/ed/codigo-fuente#slide=9
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Ejemplo: documentando código (no Javadoc) 

8lunes, 27 de abril de 2020

public class Calculadora {
public static float a(float b, float c) {…}
public static float dividir(float a, float b){…}

}

cualquier persona ajena al código desarrollado y que lo desee utilizar, debe poder con 
la documentación interpretar qué hace, y cerciorarse cómo es que se usa.

“
”

https://cs.uns.edu.ar/~federico.joaquin/web/explanations/students/ed/codigo-fuente#slide=9
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Ejemplo: documentando código (no Javadoc) 

9lunes, 27 de abril de 2020

public class Calculadora {
public static float a(float b, float c) {…}
public static float dividir(float a, float b){…}
// Computa la división real entre dos valores.
// Parámetro a: valor del dividendo de la división.
// Parámetro b: valor del divisor de la división.
// Retorna: resultado de aplicar la división.
// Lanza: ErrorException en caso de que el divisor sea cero.
public static float dividir(float a, float b) throws ErrorException{…}

}

cualquier persona ajena al código desarrollado y que lo desee utilizar, debe poder con 
la documentación interpretar qué hace, y cerciorarse cómo es que se usa.

“
”

https://cs.uns.edu.ar/~federico.joaquin/web/explanations/students/ed/codigo-fuente#slide=9
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Ejemplo: documentando código (no Javadoc) 

10lunes, 27 de abril de 2020

public class Calculadora {
public static float a(float b, float c) {…}
public static float dividir(float a, float b){…}
// Computa la división real entre dos valores.
// Parámetro a: valor del dividendo de la división.
// Parámetro b: valor del divisor de la división.
// Retorna: resultado de aplicar la división.
// Lanza: ErrorException en caso de que el divisor sea cero.
public static float dividir(float a, float b) throws ErrorException{…}
// Computa la división real entre dos valores.
// Parámetro dividendo: valor del dividendo de la división.
// Parámetro divisor: valor del divisor de la división.
// Retorna: resultado de aplicar la división.
// Lanza: DivisionPorCero en caso de que el divisor sea cero.
public static float dividir(float dividendo, float divisor) throws DivisionPorCero{…}

}

cualquier persona ajena al código desarrollado y que lo desee utilizar, debe poder con 
la documentación interpretar qué hace, y cerciorarse cómo es que se usa.

“
”

https://cs.uns.edu.ar/~federico.joaquin/web/explanations/students/ed/codigo-fuente#slide=9
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Generando Javadoc: palabras claves 

11lunes, 27 de abril de 2020

Tag Descripción Uso

@author Nombre del desarrollador. nombre_autor

@deprecated
Indica que el método o clase es antigua y que no se recomienda
su uso porque posiblemente desaparecerá en versiones
posteriores.

descripción

@param
Definición de un parámetro de un método, es requerido para
todos los parámetros del método.

nombre_parametro descripción

@return
Informa de lo que devuelve el método, no se puede usar en
constructores o métodos "void".

descripción

@see Asocia con otro método o clase.
referencia (#método(); clase#método(); 
paquete.clase; paquete.clase#método()).

@throws Excepción lanzada por el método nombre_clase descripción

@version Versión del método o clase. versión

o Javadoc define etiquetas para indicar qué tipo de elemento de la
documentación se está describiendo. Algunas de ellas:
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Ejemplo: documentando código (Javadoc) 

12lunes, 27 de abril de 2020

/**
* Modela las operaciones de una calculadora.
* @author Federico Joaquín (federico.joaquin@cs.uns.edu.ar)
*/
public class Calculadora {
/**
* Computa la división real entre dos valores.
* @param dividendo Valor del dividendo de la división.
* @param divisor Valor del divisor de la división.
* @return Resultado de aplicar la división.
* @throws DivisionPorCero en caso que divisor sea cero.
*/
public static float dividir(float dividendo, float divisor) throws DivisionPorCero{…}
}

cualquier persona ajena al código desarrollado y que lo desee utilizar, debe poder con 
la documentación interpretar qué hace, y cerciorarse cómo es que se usa.

“
”

https://cs.uns.edu.ar/~federico.joaquin/web/explanations/students/ed/codigo-fuente#slide=9
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Ejemplo: documentando código (Javadoc) 

13lunes, 27 de abril de 2020

o La documentación se exporta fuera de la IDE haciendo uso del ejecutable
javadoc que viene incluído en el JDK instalado. Ej: javadoc.exe Pila.java

o Desde la IDE Eclipse, se selecciona la clase, paquete o proyecto para el que
se desea generar la documentación, y luego: File→Exportar→ Javadoc.

o Siguiendo los pasos del asistente hay que indicar el destino de la carpeta de
documentación, así como también se debe indicar la ubicación del
ejecutable javadoc (carpeta de instalación de la jdk../bin/javadoc.exe)



Para tener en
cuenta…
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Interfaces de los TDAs usados en la materia
o En esta materia, todas las interfaces que se usarán ya

se encuentran documentadas.
o Las interfaces están disponibles en la página de la

materia y son las que deben utilizar para programar en
esta materia.

o Javadoc permite “heredar” la documentación de una
interfaz en una clase que la implementa mediante la
palabra clave @Override.

o Entonces, ¿qué es lo que deben documentar los alumnos
en sus implementaciones?

1) Encabezado de las clases.
2) Constructores.
3) Métodos privados y auxiliares.
4) Encabezado y constructores de excepciones.
5) Las clases auxiliares (ej. GUIs) que no implementan interfaces.
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TEST UNITARIO 
EN JAVA:
JUNIT

15lunes, 27 de abril de 2020

Se recomienda que todo lo documentado en la siguiente sección sea complementado a través de
otras herramientas multimedia dispuestas en la siguiente explicación online.

https://cs.uns.edu.ar/~federico.joaquin/web/explanations/students/ed/herramientas-utiles-para-tdas
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¿Qué es JUnit?
o JUnit es un conjunto de bibliotecas que son utilizadas en programación para

hacer pruebas unitarias de aplicaciones Java.

• Una prueba unitaria es una forma de comprobar el correcto funcionamiento
de una unidad de código.

• En nuestro caso, las unidades de código serán los TDAs implementados.

o JUnit es un framework que permite evaluar el funcionamiento de los métodos
de una clase.

o En función de algún valor de entrada permite evaluar el valor de retorno
esperado; si la clase cumple con la especificación, entonces JUnit indicará que el
método pasó exitosamente la prueba; en caso de que el valor esperado sea
diferente al esperado, JUnit devolverá un fallo en el método correspondiente.

lunes, 27 de abril de 2020 16
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¿Qué es JUnit?
o Esta materia no tiene por objetivo el aprendizaje de cómo se definen los casos

de pruebas en JUnit, sino que se usarán casos de test definidos por la cátedra
para validar la correctitud de las operaciones de los TDAs.

o Quedan los alumnos en total libertad de indagar, consultar e interiorizarse sobre
cómo los tests se definen, qué herramientas presenta JUnit para tal fin, y aun
más, se pueden definir nuevos casos de prueba.

17lunes, 27 de abril de 2020

En la materia es obligatorio para la aprobación del proyecto, por caso, que los
TDAs solicitados reporten que todas las operaciones definidas en estos
retornan resultados exitosos cuando son analizadas por los tests definidos para
tales TDAs. Es importante en este sentido, que las implementaciones que los
alumnos realicen sean validadas de forma permanente por estos tests.
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¿Cómo utilizar los test definidos en JUnit?
o Primero es necesario que el proyecto Java contenga el framework JUnit (librería). 

o Click derecho en el proyecto → Build Path→ Configure Build Path..

o En la pestaña Libraries→ Add Library…

o Seleccionar la librería JUnit→Next→ JUnit X (X es la versión que se disponga).

18lunes, 27 de abril de 2020
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¿Cómo utilizar los test definidos en JUnit?
o Luego, la clase que define el test debe colocarse dentro del proyecto. Considerar por

ejemplo cómo utilizar la clase StackTest.java definida por la cátedra:

o Copiar y pegar StackTest.java en el paquete TDAPila.

o Modificar en el método getStack() el nombre de la clase a testear (colocar el nombre de 
la clase que se desarrolló e implementa a Stack).

o Ejecutar el test con Run.

19lunes, 27 de abril de 2020
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EXPORTAR E IMPORTAR
CÓDIGO JAVA: 
JAR

20lunes, 27 de abril de 2020

Se recomienda que todo lo documentado en la siguiente sección sea complementado a través de
otras herramientas multimedia dispuestas en la siguiente explicación online.

https://cs.uns.edu.ar/~federico.joaquin/web/explanations/students/ed/herramientas-utiles-para-tdas
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Introducción
o La reutilización del código es una parte crucial del desarrollo de software.

o Muchas veces no se dispone del código fuente de determinadas funcionalidades, 
pero por el contrario, se dispone de librerías que encapsulan y permiten utilizar 
dicha funcionalidad.

o Para permitir el uso de funcionalidad desarrollada en Java de la que no se dispone 
del código fuente, se utilizan las librerías externas.

• A veces se usarán desarrollos en Java empaquetados en un librería externa
que hay que importar.

• A veces se desarrollará código Java que, una vez finalizado, se ofrecerá de
forma empaquetada como una librería que debe ser exportada.

21lunes, 27 de abril de 2020
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Exportando funcionalidad 
o Para exportar funcionalidad, se deben seguir los siguientes pasos:

• Click derecho sobre el proyecto/paquete/clase a exportar→ Exportar.

• Seleccionar JAR File→Next→ Seleccionar destino→ Finish.

22lunes, 27 de abril de 2020
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Exportando funcionalidad como JAR ejecutable 

o Para exportar funcionalidad como JAR ejecutable, hacer:

• Click derecho sobre el proyecto/paquete/clase a exportar→Exportar.

• Seleccionar Runnable JAR File→ Next→ Seleccionar destino e indicar la clase
Launcher (lanzador/main)→ Finish.

23lunes, 27 de abril de 2020
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Importando funcionalidad 
o Para importar funcionalidad, se deben seguir los siguientes pasos:

• Click derecho en el proyecto→ Build Path→Configure Build Path..

• En la pestaña Libraries→Add External JARs...→ Seleccionar JAR→Apply.

24lunes, 27 de abril de 2020



Fin de la presentación.
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